Unable to deposit wbtc/badger

Hi, i added liquidity to wbtc/badger pair on uniswap, but the https://app.badger.finance/ shows nothing to deposit (previously, before pairing, it correctly showed badger amount)
pls help me with this issue

Clear your browser cache and try again.

i did it, same result

also, just in case, the site always shows ‘0h 0m since last cycle’

can there be a minimum amount to stake?

Hello, hope you are having a good day.

This might be an UI issue, or probably cache issues, as the other badger said you can try clearing your cache, using a different browser or entering with Incognito, if the problem persists you can use https://vfat.tools/badger/ and stake that way. If you need help with usis vfat.tools come to #support in Discord and I will help you out.

can there be a minimum amount to stake?

And no, there is no minimum amount to stake, you don’t need to be a whale to participate in Badger! :slight_smile:

many thanks, i finally succeded via mobile metamask app - laptop via chrome still doesnt work though

Good to hear! I just tried to do a transaction with Chrome and it works on my end, so it is probably something related to your browser, maybe next time clear cache or to be 100% sure it works you can uninstall Chrome and install it again, anyways glad you sorted it out.